flutter--关于克隆GitHub项目上flutterSDK版本设置

作为一个4年多Android开发者  最近开始学习flutter;首先想到的就是clone大名鼎鼎的阿里flutter-go项目https://github.com/alibaba/flutter-go
直接打开终端  git clone https://github.com/alibaba/flutter-go.git  运行这个命令
克隆的时候,因为这个项目比较大,如果没有科学上网的话,会报错接收的文件太大,
所以可以使用git clone git://github.com/alibaba/flutter-go.git这个命令再次克隆 ,基本就能成功了
 

克隆完成以后,当你用AndroidStudio打开项目,运行发现一堆报错,这是什么原因喃?
这其实就是flutter sdk 的版本不对,但是很多包找不到,以及一些插件不能匹配
这个时候就涉及到设置flutter 版本  dart的版本了。

首先我们在flutter-go项目项目看到这样一个信息

《flutter--关于克隆GitHub项目上flutterSDK版本设置》我们运行 flutter –version
《flutter--关于克隆GitHub项目上flutterSDK版本设置》
可以看到  我们的flutter版本是最新的1.19.0,而flutter-go项目的要求是1.7.8,所以肯定是报错的
这个时候我就是设置我们flutter 版本
首先,在终端输入 flutter version 1.7.8,这个命令就是将flutter 的版本切换到1.7.8《flutter--关于克隆GitHub项目上flutterSDK版本设置》

属于y ,确认切换到1.7.8,等待下载完成以后;
使用命令: flutter channel beta,
flutter channel是切换到某个渠道命令,beta是flutter-go项目使用的版本渠道
flutter 有四个渠道 master stable beta dev ,具体使用哪个渠道,要看你clone的项目使用的渠道是哪个
最后使用 flutter channel  查看当前渠道,看到beta签名打勾了  环境切换完成
最后只需要在flutter-go项目  使用flutter packages get更新sdk信息 再次运行就不会报错
如果还报找不到类的地方   删除那个M开头的类的使用,项目就可以跑起来了

 

    原文作者:w121963433
    原文地址: https://blog.csdn.net/u012356913/article/details/106897192
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞