DevExpress控件与VS和.NET各个版本的支持情况

如下图所示,绿色Yes代表支持,红色No代表不支持。对于有些人觉得装了dev后,vs工具箱没有,一般都是以下两大问题:
1、要么你的Dev的版本不支持你当前的VS版本,没有很正常。
2、要么你的项目的.net版本并不支持当前版本Dev,修改项目的.net版本即可
另外如果以上都没有问题的话,还有其他两种情况
1、请记住安装顺序,先装VS,后装Dev,理由不需要解释自然懂;
2、以上都没问题的话,工具箱还是没有dev的控件的话,但是VS工具栏有DevExpress选项卡,则可以选择Repair Tool(重置工具箱:可以右击工具箱,或者选择DevExpress选项卡),
如果VS工具栏上没有DevExpress选项卡的话,请到安装路径找到exe修复Dev。

DevExpress各大版本支持的VS版本和支持的.net版本图(本文主要针对Winform说明)

Winform 最新

先决条件

2020年3月17日
本文档包含有关安装和使用 DevExpress WinForms 控件的系统要求的信息。

.NET 框架

下表突出显示了支持的 .NET 框架版本。

《DevExpress控件与VS和.NET各个版本的支持情况》
随着 .NET 框架 4.5 的发布,Microsoft 已停止对 .NET 客户端配置文件的支持。DevExpress 控件不支持以 v14.2 开头的 .NET 客户端配置文件。

.NET Core

下表显示了支持 .NET Core 的 DevExpress WinForms 控件的版本。

《DevExpress控件与VS和.NET各个版本的支持情况》

构建 .NET 核心应用程序的先决条件:

Visual Studio 2019 v16.6+ (包括对 .NET 5.0 的支持)
Visual Studio 2019 v16.4+ Visual Studio 2019 v16.4+ (包括支持 .NET Core 3.1)
Visual Studio 2019 v16.3 (包括支持 .NET Core 3.0)
有关详细信息,请参阅.NET Core支持

Ide

下表突出显示了 DevExpress WinForms 控件支持的Visual Studio 版本。

《DevExpress控件与VS和.NET各个版本的支持情况》

其他版本

《DevExpress控件与VS和.NET各个版本的支持情况》

从 18.2 版开始,DevExpress 源代码面向 C# 6.0。您仍然可以在 Visual Studio 2012 和 2013 中使用我们预编译的程序集。但是,无法在这些 Visual Studio 版本中重新编译 DevExpress 源代码。

对于 .NET 和 .NET Framework 应用程序开发,您需要在 Visual Studio 中安装.Net 桌面开发工作负载。有关详细信息,请参阅此文章:修改 Visual Studio 工作负载、组件和语言包

注意

  • 从 v18.2.7开始

** 从 v18.1.11开始

Visual Studio Express版本可能不支持 DevExpress WinForms 控件的所有设计时功能。

如果您需要 DevExpress 产品的早期版本,请登录 DevExpress 网站上的下载管理器页面

WPF

本文档包含有关安装和使用 DevExpress WPF 控件的系统要求的信息。

.NET 框架

下表突出显示了支持的 .NET 框架版本。
《DevExpress控件与VS和.NET各个版本的支持情况》

.NET Core

下表显示了支持 .NET Core 的 DevExpress WPF 控件的版本。
《DevExpress控件与VS和.NET各个版本的支持情况》
构建 .NET 核心应用程序的先决条件:

视觉工作室 2019 v16.4+ (包括支持 .NET Core 3.1)
Visual Studio 2019 v16.3 (包括支持 .NET Core 3.0)

Ide

下表突出显示了 DevExpress WPF 控件支持的可视化工作室版本。

下表突出显示了 DevExpress WPF 控件支持的 Visual Studio 版本。

《DevExpress控件与VS和.NET各个版本的支持情况》

注意*从版本 18.2 开始,DevExpress 源代码目标为 C# 6.0。您仍可以在 Visual Studio 2012 和 2013 中使用我们预先编译的程序集。但是,无法在这些 Visual Studio 版本中重新编译 DevExpress 源代码。

附:VS2022下使用DevExpress21.2.6破解下载(仅用于学习目的,商业使用请使用正版)。

链接:https://pan.baidu.com/s/1AYzZhdZ3fWtu8T1ylXmlZw
提取码:3rev

《DevExpress控件与VS和.NET各个版本的支持情况》

《DevExpress控件与VS和.NET各个版本的支持情况》

参考文章

.NET敏捷开发框架-RDIFramework.NET V5.1发布(跨平台)

RDIFramework.NET — 基于.NET的快速信息化系统开发框架 — 系列目录

RDIFramework.NET敏捷开发框架 ━ 工作流程组件介绍

微信公众号开发系列-玩转微信开发-目录汇总

史上最全面的SignalR系列教程-目录汇总

RDIFramework.NET敏捷开发框架 ━ 工作流程组件Web业务平台

RDIFramework.NET敏捷开发框架通过SignalR技术整合即时通讯(IM)

    原文作者:.NET敏捷开发框架
    原文地址: https://www.cnblogs.com/huyong/p/16153799.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞