python3.5上使用virtualenv创建虚拟环境的坑

一、坑一:安装的virtualenv版本太高

 

  显示使用virtualenv 安装虚拟环境报错  

  《python3.5上使用virtualenv创建虚拟环境的坑》

 

  出现这个问题就是说明你的virtualev安装的版本太高,降低一下版本重新安装即可,我这里使用的是15这个版本

  pip install virtualenv==15.0.0 

 

二、坑2:pip的版本太高

 

  《python3.5上使用virtualenv创建虚拟环境的坑》

 

   如果出现上面的错误,说明你的pip的版本太高,没办法,只能说是python3.5的版本太低了,工作历史遗留问题,没办法,必须要使用python3.5,只能乖乖将pip的版本

  python3.5最高支持pip=20的版本

  所以解决方案:将本机的pip版本降到20或20一下。

  通过:python3 -m pip install pip==20.3.4 安装指定版本

  安装好了以后在/usr/local/lib/python3.5/dist-packages下

  《python3.5上使用virtualenv创建虚拟环境的坑》

 

  然后再将这两个文件复制到我们创建的虚拟环境中  

  《python3.5上使用virtualenv创建虚拟环境的坑》

 

   OK! 万事妲己!!!

 

 

  

    原文作者:Se7eN_HOU
    原文地址: https://www.cnblogs.com/Se7eN-HOU/p/16175633.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞