解决easyExcel和poi版本冲突问题

《解决easyExcel和poi版本冲突问题》

由于easyExcel自带依赖于3.17的poi,所以如果项目其它地方引入了其它版本的poi,就会导致easyExcel导出失败等一系列问题,主要原因是因为poi版本冲突导致的,这里我提供的解决办法是,引入easyExcel的时候,排除easyExcel中自带的poi依赖。

本方法已通过博主的亲自实践,方法有效解决版本冲突导致的一系列的问题。在网上查询相关资料的时候,发现解决方法有很多,这个解决方法并不是唯一的解决办法,由于时间精力有限,其它的方法就没有去进行实践验证了,有兴趣的可以查找相关资料实践。

   <!--集成EasyExcel -->
        <dependency>
            <groupId>com.alibaba</groupId>
            <artifactId>easyexcel</artifactId>
            <version>2.2.6</version>
            <exclusions>
                <exclusion>
                    <groupId>javax.servlet</groupId>
                    <artifactId>servlet-api</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.apache.poi</groupId>
                    <artifactId>poi</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.apache.poi</groupId>
                    <artifactId>poi-ooxml</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.apache.poi</groupId>
                    <artifactId>poi-ooxml-schemas</artifactId>
                </exclusion>
            </exclusions>
         </dependency>

    原文作者:Roc-xb
    原文地址: https://blog.csdn.net/qq_19309473/article/details/114684616
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞