Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址

期末考查评分标准 A

一、任务描述

在某公司通过一个路由器与公网互联,内网通过一台交换机将所有电脑互联,在交换机上面划分两个VLAN,公司内部的PC通过各自所在的VLAN自动获取IP地址,然后去访问公网上面的Web服务器。本任务的实验拓扑如图所示:

二、拓扑结构与训练要求

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

三、相关基础知识、概念与网络设备:DHCP、VLAN、DNS、NAT、路由器、交换机等

DHCPDynamic Host Configuration Protocol,动态主机配置协议)通常被应用在大型的局域网络环境中,主要作用是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用率。

DHCP协议采用客户端/服务器模型,主机地址的动态分配任务由网络主机驱动。当DHCP服务器接收到来自网络主机申请地址的信息时,才会向网络主机发送相关的地址配置等信息,以实现网络主机地址信息的动态配置。DHCP具有以下功能:

1. 保证任何IP地址在同一时刻只能由一台DHCP客户机所使用。

2. DHCP应当可以给用户分配永久固定的IP地址。

3. DHCP应当可以同用其他方法获得IP地址的主机共存(如手工配置IP地址的主机)。

4. DHCP服务器应当向现有的BOOTP客户端提供服务。

DHCP有三种机制分配IP地址:

1) 自动分配方式(Automatic Allocation),DHCP服务器为主机指定一个永久性的IP地址,一旦DHCP客户端第一次成功从DHCP服务器端租用到IP地址后,就可以永久性的使用该地址。

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

2) 动态分配方式(Dynamic Allocation),DHCP服务器给主机指定一个具有时间限制的IP地址,时间到期或主机明确表示放弃该地址时,该地址可以被其他主机使用。

3) 手工分配方式(Manual Allocation),客户端的IP地址是由网络管理员指定的,DHCP服务器只是将指定的IP地址告诉客户端主机。

三种地址分配方式中,只有动态分配可以重复使用客户端不再需要的地址。

DHCP消息的格式是基于BOOTPBootstrap Protocol)消息格式的,这就要求设备具有BOOTP中继代理的功能,并能够与BOOTP客户端和DHCP服务器实现交互。BOOTP中继代理的功能,使得没有必要在每个物理网络都部署一个DHCP服务器。RFC 951RFC 1542BOOTP协议进行了详细描述

VLANVirtual Local Area Network)的中文名为虚拟局域网

虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

在计算机网络中,一个二层网络可以被划分为多个不同的广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同的广播域是相互隔离的。不同的广播域之间想要通信,需要通过一个或多个路由器。这样的一个广播域就称为VLAN

DNSDomain Name System域名系统),万维网上作为域名和IP地址相互映射的一个分布式数据库,能够使用户更方便的访问互联网,而不用去记住能够被机器直接读取的IP数串。通过域名,最终得到该域名对应的IP地址的过程叫做域名解析(或主机名解析)。DNS协议运行在UDP协议之上,使用端口号53

DNS功能

每个IP地址都可以有一个主机名,主机名由一个或多个字符串组成,字符串之间用小数点隔开。有了主机名,就不要死记硬背每台IP设备的IP地址,只要记住相对直观有意义的主机名就行了。这就是DNS协议的功能。

主机名到IP地址的映射有两种方式:

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

 

1)静态映射,每台设备上都配置主机到IP地址的映射,各设备独立维护自己的映射表,而且只供本设备使用;

2)动态映射,建立一套域名解析系统(DNS),只在专门的DNS服务器上配置主机到IP地址的映射,网络上需要使用主机名通信的设备,首先需要到DNS服务器查询主机所对应的IP地址 [1] 

通过主机名,最终得到该主机名对应的IP地址的过程叫做域名解析(或主机名解析)。在解析域名时,可以首先采用静态域名解析的方法,如果静态域名解析不成功,再采用动态域名解析的方法。可以将一些常用的域名放入静态域名解析表中,这样可以大大提高域名解析效率

NATNetwork Address Translation,网络地址转换)是1994年提出的。当在专用网内部的一些主机本来已经分配到了本地IP地址(即仅在本专用网内使用的专用地址),但现在又想和因特网上的主机通信(并不需要加密)时,可使用NAT方法。

这种方法需要在专用网连接到因特网的路由器上安装NAT软件。装有NAT软件的路由器叫做NAT路由器,它至少有一个有效的外部全球IP地址。这样,所有使用本地地址的主机在和外界通信时,都要在NAT路由器上将其本地地址转换成全球IP地址,才能和因特网连接。

NAT的实现方式有三种,即静态转换Static Nat、动态转换Dynamic Nat和端口多路复用OverLoad

静态转换是指将内部网络的私有IP地址转换为公有IP地址,IP地址对是一对一的,是一成不变的,某个私有IP地址只转换为某个公有IP地址。借助于静态转换,可以实现外部网络对内部网络中某些特定设备(如服务器)的访问。

动态转换是指将内部网络的私有IP地址转换为公用IP地址时,IP地址是不确定的,是随机的,所有被授权访问上Internet的私有IP地址可随机转换为任何指定的合法IP地址。也就是说,只要指定哪些内部地址可以进行转换,以及用哪些合法地址作为外部地址时,就可以进行动态转换。动态转换可以使用多个合法外部地址集。当ISP提供的合法IP地址略少于网络内部的计算机数量时。可以采用动态转换的方式。

端口多路复用(Port address Translation,PAT)是指改变外出数据包的源端口并进行端口转换,即端口地址转换PATPort Address Translation).采用端口多路复用方式。内部网络的所有主机均可共享一个合法外部IP地址实现对Internet的访问,从而可以最大限度地节约IP地址资源。同时,又可隐藏网络内部的所有主机,有效避免来自internet的攻击。因此,目前网络中应用最多的就是端口多路复用方式。

路由器(Router),是连接因特网中各局域网广域网的设备,它会根据信道的情况自动选择和设定路由,以最佳路径,按前后顺序发送信号。 路由器是互联网络的枢纽,交通警察目前路由器已经广泛应用于各行各业,各种不同档次的产品已成为实现各种骨干网内部连接、骨干网间互联和骨干网与互联网互联互通业务的主力军。路由和交换机之间的主要区别就是交换机发生在OSI参考模型第二层(数据链路层),而路由发生在第三层,即网络层。这一区别决定了路由和交换机在移动信息的过程中需使用不同的控制信息,所以说两者实现各自功能的方式是不同的。

路由器(Router)又称网关设备Gateway)是用于连接多个逻辑上分开的网络,所谓逻辑网络是代表一个单独的网络或者一个子网。当数据从一个子网传输到另一个子网时,可通过路由器的路由功能来完成。因此,路由器具有判断网络地址和选择IP路径的功能,它能在多网络互联环境中,建立灵活的连接,可用完全不同的数据分组和介质访问方法连接各种子网,路由器只接受源站或其他路由器的信息,属网络层的一种互联设备。

交换机(Switch)意为开关是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。最常见的交换机是以太网交换机。其他常见的还有电话语音交换机、光纤交换机等。

四、配置步骤

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

配置代码:
########################################
Server
Router>en
Router#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#host Server
Server(config)#line con 0
Server(config-line)#logg syn
Server(config-line)#exec-timeout 0 0
Server(config-line)#exit
Server(config)#int s0/0/0
Server(config-if)#ip add 202.1.1.1 255.255.255.0
Server(config-if)#ip nat outside
Server(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Server(config-if)#exit
Server(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Server(config)#ip nat inside source list 1 interface s0/0/0
Server(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
Server(config)#exit
########################################
ISP
Router>en
Router#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host ISP
ISP(config)#no ip domain-lookup
ISP(config)#line con 0
ISP(config-line)#logg syn
ISP(config-line)#exec-timeout 0 0
ISP(config-line)#exit
ISP(config)#int s0/0/0	
ISP(config-if)#ip add 202.1.1.2 255.255.255.0
ISP(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

ISP(config-if)#
ISP(config-if)#clock rate 64000
ISP(config-if)#exit
ISP(config)#int f0/0
ISP(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

ISP(config-if)#ip add 202.2.2.2 255.255.255.0
ISP(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

ISP(config-if)#
ISP(config-if)#int f0/1
ISP(config-if)#ip add 202.3.3.3 255.255.255.0
ISP(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

ISP(config-if)#
ISP(config-if)#
########################################
Server#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Server#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Server(config)#int f0/0.1
Server(config-subif)#encapsulation dot1Q 2
Server(config-subif)#ip add 192.168.1.1 255.255.255.0
Server(config-subif)#no shut
Server(config-subif)#exit
Server(config)#int f0/0.2
Server(config-subif)#encapsulation dot1Q 3
Server(config-subif)#ip add 192.168.2.1 255.255.255.0
Server(config-subif)#no shut
Server(config-subif)#exit
Server(config)#ip dhcp pool vlan2
Server(dhcp-config)#network 192.168.1.0 255.255.255.0
Server(dhcp-config)#dns 202.2.2.1
Server(dhcp-config)#default-router 192.168.1.1
Server(dhcp-config)#exit
Server(config)#ip dhcp pool vlan3
Server(dhcp-config)#network 192.168.2.0 255.255.255.0
Server(dhcp-config)#dns 202.2.2.1
Server(dhcp-config)#default-router 192.168.2.1
Server(dhcp-config)#exit
Server(config)#ip dhcp excluded-address 192.168.1.1
Server(config)#ip dhcp excluded-address 192.168.2.1
Server(config)#access-list 1 permit 192.168.2.0 0.0.0.255
Server(config)#exit
Server#
%SYS-5-CONFIG_I: Configured from console by console

Server#config
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Server(config)#int f0/0.1
Server(config-subif)#ip nat inside
Server(config-subif)#exit
Server(config)#int f0/0.2
Server(config-subif)#ip nat inside
Server(config-subif)#exit
Server(config)#
Server(config)#interface FastEthernet0/0
Server(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Server(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up
%LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.2, changed state to up
Server(config-if)#
########################################

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

五、测试与结果

  • 在内网路由器Server上配置DHCP,实现下连交换机上处于不同Vlan的电脑获得相应的IP地址。
  • 查看公司内网的所有PC是正确分配到自己所在的VLAN的相应的IP地址。
  • 在PC上使用浏览器能通过www.cisco.com的域名访问ISP端的WWW服务器的网页。

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

《Cisco配置web服务器,划分Vlan,使用DNS自动获取IP地址》

六、结束语

感谢老师的指导,感谢父母的培养,我一定好好学习,努力学好Cisco。通过这次的期末作业,使我懂了很多,也收获了很多知识,自己的动手能力和思维方式得到解放。

 

 

 

 

 

 

    原文作者:呵呵哒( ̄▽ ̄)"
    原文地址: https://blog.csdn.net/weixin_41987016/article/details/111414545
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞